Project

General

Profile

eXtplorer 2.1.1 install fails on Joomla 2.5.8

Added by Neil Robertson almost 5 years ago

Hi,

Thanks for a great free component that I install on all my Joomla websites!

eXtplorer usually installs fine but I have tried the new version on two of my websites and the following error is displayed:

Cannot redeclare class com_extplorerInstallerScript in /home/[AccountName]/public_html/administrator/components/com_extplorer/install.extplorer.php on line 49

Is anyone else also having this problem?

Thanks,

Neil


Replies (10)

RE: eXtplorer 2.1.1 install fails on Joomla 2.5.8 - Added by Geoffrey Schaller almost 5 years ago

I'm seeing something similar, but not quite the same.

I'm running Joomla 2.5.8, and can install eXtplorer 2.1.0 without problems.

When I attempt to upgrade, I get the message that the folders are in use (detailed elsewhere on these forums), but I still get a message that the new component was installed (it was not, 2.1.0 is still the installed version).

When I uninstall 2.1.0, and then install 2.1.1 fresh, I get an error page:

"HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request."

eXtplorer 2.1.1 will not be installed - it's not listed in the Admin Menus, or in the Extension Manager - but the folders under /administrator/components and /components will be there, and I need to delete them manually to try again, or to re-install 2.1.0

I am running Akeeba Admin Tools, with the .htaccess enabled, and the exception "Allow direct access to these files" is enabled for administrator/components/com_extplorer/fetchscript.php

Is something else blocking / preventing the install of eXtplorer 2.1.1?

RE: eXtplorer 2.1.1 install fails on Joomla 2.5.8 - Added by Rudolf Knoetzen almost 5 years ago

Fatal error: Cannot redeclare class com_extplorerInstallerScript in /home/agrifarm/public_html/administrator/components/com_extplorer/install.extplorer.php on line 49

same error on my side - server is php 5.4.7 - maybe that is a problem?

RE: eXtplorer 2.1.1 install fails on Joomla 2.5.8 - Added by Rudolf Knoetzen almost 5 years ago

trying to revert back to 2.1 gives me

Strict Standards: Non-static method extArchive::extract() should not be called statically in /home/agrifarm/public_html/administrator/components/com_extplorer/install.extplorer.php on line 28

Strict Standards: Non-static method extFile::getExt() should not be called statically in /home/agrifarm/public_html/administrator/components/com_extplorer/libraries/Archive/archive.php on line 36

Strict Standards: Non-static method extFile::stripExt() should not be called statically in /home/agrifarm/public_html/administrator/components/com_extplorer/libraries/Archive/archive.php on line 38

Strict Standards: Non-static method extFile::getExt() should not be called statically in /home/agrifarm/public_html/administrator/components/com_extplorer/libraries/Archive/archive.php on line 38

Strict Standards: Non-static method PEAR::isError() should not be called statically in /home/agrifarm/public_html/administrator/components/com_extplorer/install.extplorer.php on line 29

this was working and i moved to new server with php 5.4.7 which was the differece and i think that might be the problem.

RE: eXtplorer 2.1.1 install fails on Joomla 2.5.8 - Added by Rudolf Knoetzen almost 5 years ago

my hosting asked me to add the folowing line to .htaccess which solved the problem and underline the fact that the problem is php 5.4.

AddHandler application/x-httpd-php53 .php .php5

RE: eXtplorer 2.1.1 install fails on Joomla 2.5.8 - Added by Geoffrey Schaller almost 5 years ago

I'm on PHP 5.3, so that won't work for me, unfortunately...

PHP Built On: Linux vps.psi-13.com 2.6.18-274.18.1.el5.028stab098.1 #1 SMP Sat Feb 11 15:30:41 MSK 2012 x86_64
Database Version: 5.0.96-community
Database Collation: utf8_general_ci
PHP Version: 5.3.13
Web Server: Apache/2.2.22 (Unix) mod_ssl/2.2.22 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635
WebServer to PHP Interface: cgi-fcgi
Joomla! Version: Joomla! 2.5.8 Stable [ Ember ] 8-November-2012 14:00 GMT
Joomla! Platform Version: Joomla Platform 11.4.0 Stable [ Brian Kernighan ] 03-Jan-2012 00:00 GMT

RE: eXtplorer 2.1.1 install fails on Joomla 2.5.8 - Added by Ervin Deak almost 5 years ago

Hi,

I had similar problems. First http 500 error, because error reporting was too low. After I set it to a higher value I got the "Cannot redeclare class com_extplorerInstallerScript" error. So I repaired with some verision check. But then I got new "Cannot redeclare something" errors. I repaired those errors too, so finally installation was successfull. And the component works as well.

@Rudolf Knoetzen: try to lowering the error reporting level. Those aren't serious errors. Don't bother with them.

com_extplorer_2.1.1.zip - -- with fixed install script (1.94 MB)

RE: eXtplorer 2.1.1 install fails on Joomla 2.5.8 - Added by Sören Eberhardt-Biermann almost 5 years ago

Hi Ervin,

thanks for working on the problem! I will include your fixes in the next version.

Sören

[Solved] eXtplorer 2.1.1 install fails on Joomla 2.5.8 - Added by Neil Robertson almost 5 years ago

Thanks Ervin and Sören! The installation works fine for me now.

All the best,

Neil.

RE: eXtplorer 2.1.1 install fails on Joomla 2.5.8 - Added by Manos Lectrus almost 5 years ago

Hi all, I tried to install the version 2.1.3 on Joomla! 2.5.8 and it doesn't work. I receive all the time the "500 error page". Why the problem continues on this version? Any idea? Thank you.

Sören Eberhardt-Biermann wrote:

Hi Ervin,

thanks for working on the problem! I will include your fixes in the next version.

Sören

RE: eXtplorer 2.1.1 install fails on Joomla 2.5.8 - Added by dimitry staeren almost 5 years ago

i have also in joomla 2.5.8 a similar installation problem. I always get a message like: DB no problem, can't remove scripts.tar.gz...
There are no files copied to /administrator/components/com_extplorer. Even this map is not created.

    (1-10/10)