Project

General

Profile

Fehler #148

Install eXtplorer on My Book World Edition White Light

Added by Patrick BRIOT almost 4 years ago. Updated almost 4 years ago.

Status:
Neu
Priority:
Normal
Category:
Bug
Target version:
eXtplorer Version:
2.1.2
Joomla! Version:
none

Description

Hello,
First, your explorer is amazing and exactly what i need on my NAS. It is on PHP 4.4.2 and if possible i prefer to stay on it.

I'm almost a noob on linux and a real one on JSON.

eXtplorer is almost working on my NAS.

First Bug, on first start, click "Connect" after typing usr/pwd doesn't start success on handler and so "location.load", but if i click on refresh button on browser (IE10 or Chrome 30.0) credentials are accepted.

Second Bug, after warning message on default password, the first popup open but another popup on it inform on an issue with JSON decoding.

To use your software, i've to modify these files :
1. index.php :
add this line 1 : #!/usr/bin/php
chmod 766 on file to be executable
2. fetchscript.php :
add this line 1 : #!/usr/bin/php
chmod 766 on file to be executable
3. libraries/FTP/Socket.php :
line 507 : remove "= null" on &$msg
4. libraries/Text/TextEncoding.php :
remove all "static" before "function" (8x)

I hope my descriptions can help you to understand my issues.
I'll do what you want if you need other information, but please help me to install correctly your software.

Thanks for your help.

Best regards from France.

extplorer_Bug1.jpg - Bug 1 (42.5 KB) Patrick BRIOT, 10/30/2013 12:33 AM

extplorer_Bug2.jpg - Bug 2 (45.1 KB) Patrick BRIOT, 10/30/2013 12:33 AM

History

#1 Updated by Sören Eberhardt-Biermann almost 4 years ago

  • Target version changed from 2.1.4 to 2.1.6

Also available in: Atom PDF