Project

General

Profile

Migration from PHP 5.2 to PHP 5.4

Added by Mathieu FOURTILLAN almost 5 years ago

Hello,
my website use Joomla 2.5.6, PHP 5.2 and Extplorer 2.1.0 => All is working fine.

I must upgrade to PHP 5.4 before April 2013.
I have tried to upgrade from PHP 5.2 to PHP 5.4 => All components seems to work except Extplorer (2.1.0).

I go back to PHP 5.2 and it works fine => So it's really links to PHP version.

Do you have a solution ?
I have seen that Extplorer v2.1.1 is available (normaly for Joomla 3). Do you think it will works ? or do you have any other issue.

Regards.


Replies (9)

RE: Migration from PHP 5.2 to PHP 5.4 - Added by Thierry Vanneste almost 5 years ago

Exactly the same problem for me

OK on PHP5.2 and NOTOK on PHP5.4

RE: Migration from PHP 5.2 to PHP 5.4 - Added by Ervin Deak almost 5 years ago

Hi,

It's not so much information... some error messages? Exact problem?
I'm not a developer of this software, but a php developer and I know more information means faster repair.

RE: Migration from PHP 5.2 to PHP 5.4 - Added by astrid Ventevogel over 4 years ago

I just did a fresh install, here are the error codes:
Strict Standards: Non-static method extArchive::extract() should not be called statically in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/administrator/components/com_extplorer/install.extplorer.php on line 34

Strict Standards: Non-static method extFile::getExt() should not be called statically in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/administrator/components/com_extplorer/libraries/Archive/archive.php on line 36

Strict Standards: Non-static method extFile::stripExt() should not be called statically in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/administrator/components/com_extplorer/libraries/Archive/archive.php on line 38

Strict Standards: Non-static method extFile::getExt() should not be called statically in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/administrator/components/com_extplorer/libraries/Archive/archive.php on line 38

Strict Standards: Non-static method PEAR::isError() should not be called statically in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/administrator/components/com_extplorer/install.extplorer.php on line 35

RE: Migration from PHP 5.2 to PHP 5.4 - Added by Ervin Deak over 4 years ago

As I wrote in another topic: try to lowering the error reporting level. Those aren't serious errors. Don't bother with them.

So if you get Strict Standards errors, that means your error reporting level is development, and those lines contains code wich ain't standard but working. And means that probally will not compatible with next php releases. But these errors for software develpers to keep their codes compatible with php.

If you lowering the error reporting then they will disappear.
PHP 5.2 vs. 5.4: I think is't because from php 5.4 E_ALL includes E_STRICT and server configured to report E_ALL but not E_NOTICE. It means server reports E_STRICT too.

If there's no errors just blank page or http error 500 page you probally need to highering the error reporting to see errors. Try E_ALL without E_STRICT and E_NOTICE.
So in joomla: /administrator/index.php?option=com_config on server tab Error Reporting field will be set to simple to get php errors.

RE: Migration from PHP 5.2 to PHP 5.4 - Added by astrid Ventevogel over 4 years ago

Thanks for the explanation!
I have now a fatal error (last one in the list)
Thanx for caring

Strict Standards: Only variables should be assigned by reference in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/plugins/system/nnframework/nnframework.php on line 18

Strict Standards: Only variables should be assigned by reference in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/plugins/system/nnframework/nnframework.php on line 21

Strict Standards: Only variables should be assigned by reference in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/plugins/system/nnframework/nnframework.php on line 47

Strict Standards: Only variables should be assigned by reference in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/plugins/system/modulesanywhere/modulesanywhere.php on line 47

Strict Standards: Only variables should be assigned by reference in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/plugins/system/modulesanywhere/modulesanywhere.php on line 50

Strict Standards: Non-static method ext_Lang::detect_lang() should not be called statically in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/administrator/components/com_extplorer/include/init.php on line 103

Warning: require_once(/usr/local/php5/lib/php/PEAR.php): failed to open stream: Permission denied in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/administrator/components/com_extplorer/libraries/FTP.php on line 33

Fatal error: require_once(): Failed opening required 'PEAR.php' (include_path='.:/usr/local/php5/lib/php') in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/administrator/components/com_extplorer/libraries/FTP.php on line 33

RE: Migration from PHP 5.2 to PHP 5.4 - Added by Ervin Deak over 4 years ago



These chars above means somewhere in files there's a BOM singature for UTF-8 encoding. Outputted after the strict error in /administrator/components/com_extplorer/include/init.php and before /libraries/FTP.php so check the files wich included between those...

You can find BOM-signed files quite fastly with Total Commander. I attached a screenshot to help with settings. After you found the files edit with an advanced text editor (not Window's built-in notepad) like notepad2 or editplus or if you have adobe dreamweaver or something like, that would be best. Find some encodig settings and turn off BOM and save the file.

Warning: require_once(/usr/local/php5/lib/php/PEAR.php): failed to open stream: Permission denied in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/administrator/components/com_extplorer/libraries/FTP.php on line 33
Fatal error: require_once(): Failed opening required 'PEAR.php' (include_path='.:/usr/local/php5/lib/php') in /data/home/nano01/domains/fandor.nl/public_html/hmmigratie/jupgrade/administrator/components/com_extplorer/libraries/FTP.php on line 33

It looks like you don't have an access for pear lib, but you may has when you wrote your prevoius post, so it's possible because of BOM error or the server setting may be changed.
Try to check BOM thing, then try again, if error still appear try to ask server provider or get a pear.php form php.net and place to /administrator/components/com_extplorer/libraries/ dir. But in this case you may get another pear related errors.

tcmd-find-bom.jpg (83.6 KB)

RE: Migration from PHP 5.2 to PHP 5.4 - Added by a lec over 4 years ago

Hi,
I got "Strict Standards Errors" on a 1&1-Hosting-Package (Joomla 3, php 5.4).

I created a php.ini with the only line
display_errors = Off
and place it in the administrator folder (not the root).

After that, it was ok again.

RE: Migration from PHP 5.2 to PHP 5.4 - Added by Marc DECHEVRE over 4 years ago

Hi,
Similar problem for me : I have a Joomla 3.1 website hosted with OVH and running with a "SetEnv PHP_VER 5_4" in .htaccess file.

Installation of eXtplorer_2.1.3 went fine.

But trying to open the interface in Components, I got the error msg below.

So I "downgraded" my PHP to 5_3 (and there it works).

When is an update planned ?

Yours,

Marc

----
Strict Standards: Non-static method ext_Lang::detect_lang() should not be called statically in /homez.707/blabla/www/administrator/components/com_extplorer/include/init.php on line 103

Strict Standards: Non-static method ext_Result::init() should not be called statically in /homez.707/blabla/www/administrator/components/com_extplorer/admin.extplorer.php on line 97

Strict Standards: Non-static method ext_Result::empty_errors() should not be called statically in /homez.707/blabla/www/administrator/components/com_extplorer/include/result.class.php on line 40

Strict Standards: Non-static method ext_Result::empty_messages() should not be called statically in /homez.707/blabla/www/administrator/components/com_extplorer/include/result.class.php on line 41

Strict Standards: Declaration of ext_List::execAction() should be compatible with ext_Action::execAction($dir, $item) in /homez.707/blabla/www/administrator/components/com_extplorer/include/list.php on line 387
Back to Joomla! Mode courant: extplorer [Déconnecter]. Vous pouvez passer en mode ftp.

Strict Standards: Non-static method extHTML::loadExtJS() should not be called statically, assuming $this from incompatible context in /homez.707/blabla/www/administrator/components/com_extplorer/include/list.php on line 374

    (1-9/9)